Как на AIX правильно запустить Х-сессию???


Главная Форумы POWER Systems AIX/Hardware Как на AIX правильно запустить Х-сессию???

В этой теме 4 ответа, 4 участника, последнее обновление  Olegg 5 года/лет, 7 мес. назад.

  • Автор
    Сообщения
  • #14674

    Olegg
    Участник

    Добрый день!
    Из Xmanager запускаю xterm вот такой командой —
    /usr/bin/X11/xterm -ls -display $DISPLAY
    Но терминал не запускается… 🙁 AIX ставился по дефолту… пакеты иксов ставились…
    Вместо окна терминала получаю такое сообщение —
    $ /usr/bin/X11/xterm -ls -display 10.0.2.107:0
    /usr/bin/X11/xterm Xt error: Can’t open display: 10.0.2.107:0
    /usr/bin/X11/xterm: DISPLAY is not set
    Буду благодарен за помощь.
    Помогите разобраться.

    Спасибо.
    С уважением, Олег.

  • #14675

    andrewk
    Участник

    если у Вас на Вашей рабочей станции запущен X-сервер:

    1. проверьте, есть ли вообще соединение:
    telnet WORKSTATION 6000
    или с самой станции:
    telnet localhost 6000

    2. проверьте замечательный Windows Firewall

    3. попробуйте отключить контроль доступа.
    В нормальном UNIX — xhost +

  • #14685

    Michael
    Участник

    Я вообще-то делал:
    # xhost +
    # export DISPLAY=10.0.2.107 — примерно так.
    # xterm

    Кстати, видно же, что у Вас в сессии переменная DISPLAY не определена:

    /usr/bin/X11/xterm: DISPLAY is not set

  • #14688

    Alex
    Участник

    Кстати, видно же, что у Вас в сессии переменная DISPLAY не определена:

    При явном указании xterm-у параметра -display это не важно.

  • #14708

    Olegg
    Участник

    Добрый день! Уважаемые форумчане!!!

    Как всегда, «умных» ошибок не бывает… 🙂 🙂 🙂
    … Циски — циски…, виланы — виланы…, роутеры — роутеры….

    ОГРОМНОЕ СПАСИБО всем откликнувшимся!

Для ответа в этой теме необходимо авторизоваться.