554 unknown bootdisk


Главная Форумы POWER Systems AIX/Hardware 554 unknown bootdisk

В этой теме 0 ответов, 1 участник, последнее обновление  andrewk 6 года/лет, 1 месяц назад.

  • Автор
    Сообщения
  • #13840

    andrewk
    Участник

    разминка для мозгов. есть машинка, Power4, Intellistation 9114-275. Естественно никакой поддержки нет, машина стоит дома и я на ней тестирую всякую фигню. На машине установлен AIX 7.1. После установки все работает, машину можно перезагружать сколько угодно раз — никаких проблем. После установки TL1, либо TL0 SP2/SP3 машина при перезагрузке останавливается с кодом 554 и надписью Unknown Disk. C SP1 подобной беды в свое время замечено не было.
    Сначала грешил, что система (rootvg) находится на старых дисках от AS/400 — перенес ее на родные диски от 275го. Проблема повторилась.
    при debug-выводе при загрузке видно, что система не в состоянии определить диск, с которого она загружалась последний раз, затем выполняет bootdisk -U и на этом останавливается:

    exec(/bin/sh,-c,/usr/lib/methods/cfglvdd -1 -l lvdd){1376314,1048624}
    exec(/usr/lib/methods/cfglvdd,-1,-l,lvdd){1376314,1048624}
    Number of running methods: 1
    —————-
    Completed method for: lvdd, Elapsed time = 0
    Return code = 0
    *** no stdout ****
    *** no stderr ****
    —————-
    Time: 20 LEDS: 0x539
    Number of running methods: 0
    cfgmgr cfgmgr Configuration time: 21 seconds
    + bootinfo -i
    exec(/usr/sbin/bootinfo,-i){1048626,983070}
    exec(/usr/lib/boot/bin/bootinfo_chrp,-i){1048626,983070}
    + [ 0 -eq 1 ]
    + /usr/lib/methods/showled 0x511 DEV CFG 1 END
    exec(/usr/lib/methods/showled,0x511,DEV CFG 1 END){1048628,983070}
    showled + + bootinfo -b
    exec(/usr/sbin/bootinfo,-b){1048630,983070}
    exec(/usr/lib/boot/bin/bootinfo_chrp,-b){1048630,983070}
    dvc=
    + [ ! ]
    + bootinfo -U
    exec(/usr/sbin/bootinfo,-U){1048632,983070}
    + [ 0 -eq 1 ]
    + loopled 0x554 UNKNOWN BOOTDISK
    exec(/usr/lib/methods/showled,0x554,UNKNOWN BOOTDISK){1048634,983070}
    showled

    нашел в интернете еще один APAR (https://www-304.ibm.com/support/docview.wss?uid=isg1IZ44720) про неправильное выставление переменной bootlist в OpenFirmware — залез туда, вроде все стоит правильно. Сижу, теперь размышляю, в чем может еще быть проблема? Есть еще какие-нибудь идеи, что можно было бы перепроверить? В голову приходит еще только savebase попробовать руками перед перезагрузкой сделать.

Для ответа в этой теме необходимо авторизоваться.