HMC + LPAR — проблема с tty0


Главная Форумы POWER Systems AIX/Hardware HMC + LPAR — проблема с tty0

В этой теме 35 ответов, 7 участников, последнее обновление  andrewk 5 года/лет, 3 мес. назад.

  • Автор
    Сообщения
  • #16610

    DanGer
    Участник

    Здравствуйте!
    Желаю всем всех благ и беспроблемной работы вашей техники.
    У меня, к сожалению, не так. Есть два сервера p570, с лпарами на них. Когда пытаюсь подключиться к виртуальному терминалу с HMC получаю:
    [code]hscroot@localhost:~> mkvterm -m Server-9117-570-NODE1 -p lpar4-tsm

    Received invalid connection information, operation cancelled.
    Received end of file, Exiting.
    hscroot@localhost:~>[/code]
    C NODE2 проблем не имеется.
    Подскажите, пожалуйста, в чем проблема и как ее можно решить.
    Спасибо!

    P.S. Техподдержки нет, иначе сразу их озадачил бы.

  • #16613

    andrewk
    Участник

    rmvterm конечно же не помог? можно попробовать с особой жестокостью remove connection, а затем снова найти сервер.

  • #16615

    Sever
    Участник

    Саппорт, обычно, первым делом интересуется текущими версиями консоли и прошивок серверов.

  • #16630

    DanGer
    Участник

    Server — SF240_338
    HMC — V7R3.4.0, type 7042CR4

    rmvterm не помог.

  • #16631

    Sever
    Участник

    Прошивка от января 2008 года, консоль тоже старовата.
    Перегрузите консоль, если не поможет, то с нее и начните обновление.
    Поставьте 7.3.5.0 с последним сервиспаком.
    Рекомендуемая IBM-ом прошивка для всех power5 моделей сейчас одна — 240_417, она же и есть последняя.

    Решит ли это все вашу проблему? Гарантий нет.

    При установке последних прошивок на «пятых» 570ых машинах могут возникнуть проблемы, которые на старых уровнях просто не диагностируются. Речь идет о мониторинге работы вентиляторов. К этому надо быть готовым.

  • #16632

    Oldnick
    Участник

    Может не в тему, я читал в одной из презентаций о планах IBM на счет развития HMC. IBM планирует в скором будущем выпустить обновленный продукт, куда в качестве новинок войдут опции для обеспечения надежности работы HMC.
    Скорее всего имеются ввиду два диска и Raid-1 🙂
    Будут ли это опции к 7042-CR6 или совершенно новый сервак, пока не ясно.

    одиним словом, не прошло и 7 лет, как решили все-таки поставить второй HDD.

  • #16634

    Andriy
    Участник

    Скорее всего имеются ввиду два диска и Raid-1 🙂
    Будут ли это опции к 7042-CR6 или совершенно новый сервак, пока не ясно.

    одиним словом, не прошло и 7 лет, как решили все-таки поставить второй HDD.

    не скорее всего, точно 🙂 об этом в announcement letter было:

    Enhancement of HMC to provide RAID 1 support

    пруфлинк: http://www-01.ibm.com/common/ssi/cgi-bin/ssialias?infotype=AN&subtype=CA&htmlfid=897/ENUS212-236&appname=USN

  • #16635

    Andriy
    Участник

    Server — SF240_338
    HMC — V7R3.4.0, type 7042CR4

    rmvterm не помог.

    бутнуть консоль, затем — обновляться, да. http://www14.software.ibm.com/webapp/set2/flrt вам в помощь. там, кстати, в отличие от саппорта IBM не всегда рекомендуют последние версии прошивок 🙂

  • #16636

    DanGer
    Участник

    Ребут консоли — это первое, что я сделал. Не помогло.

    Извините за глупый вопрос: при перепрошивке сервера ЛПАР-ы будут продолжать работать? Спрашиваю потому, что тушить их нельзя. Точнее можно, но только в том случае, если это гарантированно поможет.

    И самое главное, что мне хочется понять — почему это появилось? Ведь незадолго до этого все работало.

  • #16637

    Oldnick
    Участник

    в вашем случае конкуретный апгрейд возможен только на SF240_371.
    апгрейд на SF240_382 и выше — они все требуют останова разделов.

    Если пока нет возможности обновить прошивку, для начала обновите HMC хотя бы до V7R3.5 + последний сервис-пак SP4.

    p.s.
    обновление до SF240_417 крайне рекомендуется. планируйте эту процедуру с остановкой серверов.

  • #16638

    Sever
    Участник

    Если пока нет возможности обновить прошивку, для начала обновите HMC хотя бы до V7R3.5 + последний сервис-пак SP4.
    .

    Именно так. Сначала обновите консоль, ее обновление никоим образом не затрагивает доступность серверов.

  • #16645

    MIkhail
    Участник

    А такая ситуация на все LPAR или у вас только одна?

  • #16649

    DanGer
    Участник

    На все ЛПАР-ы только этого сервера. На других серверах все нормально.

  • #16650

    MIkhail
    Участник

    Попытайтесь выполнить данные действие через vtmenu

  • #16653

    DanGer
    Участник

    Пытался. И не раз.

    Upd.
    Обновил HMC до V7R350 SP4. Толку — ноль!

  • #16664

    MIkhail
    Участник

    Можно увидить конфиг LPAR ту часть гда адаптеры.
    Еще возможно глупость, проверте включена ли опция разрешить Vterm в настройках HMC :whistle:

  • #16665

    Sever
    Участник

    Upd.
    Обновил HMC до V7R350 SP4. Толку — ноль!

    Толк есть. Ha этом уровне консоли можно обновилять прошивку до 240_417.
    Тут уже выбор за вами — делать это или нет.
    Обновление требует предварительного полного выключения всех партиций и выключения проблемного сервера с консоли HMC.

  • #16666

    DanGer
    Участник

    Да, наверное, когда-нибудь я и обновлю прошивку сервера, но сейчас это не решает моих проблем и нет гарантии, что решит вообще. Изначально топик создавался для того, чтобы понять, как вернуть нормальное соединение на нулевую консоль.

  • #16667

    DanGer
    Участник

    Извините, пожалуйста, а что Вы имеете ввиду под «конфиг LPAR ту часть гда адаптеры»?
    В настройках HMC я включил все, что можно — все равно доступ на эту подсеть только у меня :). И ранее я пользовался и vtmenu, и mkvterm и java-апплетом в веб-консоли. А теперь у меня никак не получается попасть на ЛПАР.

  • #16668

    Sever
    Участник

    все равно доступ на эту подсеть только у меня :). И ранее я пользовался и vtmenu, и mkvterm и java-апплетом в веб-консоли. А теперь у меня никак не получается попасть на ЛПАР.

    C этого и надо было начинать.
    Покажите полную топологию сети и побольше информации о «подсети, к которой доступ есть только у вас».

  • #16715

    DanGer
    Участник

    Извините за долгие ответы, не всегда есть возможность «посидеть» на форуме.
    Сеть состоит из HMC (2-x) и трех серверов. К нему доступ из других подсетей запрещен.
    Непонятно что именно мне должно мешать, если ранее все прекрасно работало. Никаких манипуляций с сетями не проводили, с настройками HMC и прошивки серверов ничего не делали.
    Тем более, как я ранее упоминал, на ЛПАР-ы других серверов все прекрасно ходит.

  • #16716

    Michael
    Участник

    У Вас две НМС. И на обоих проблемы с одним и тем же сервером и его разделами?

  • #16717

    DanGer
    Участник

    Да, оба HMC получают эту непонятную запись о получении ошибки.
    Очевидно, проблема на сервере, а не в HMC, но что конкретно не работает — непонятно. Если бы знать, что и где искать…

  • #16718

    Michael
    Участник

    Пожалуй, я бы испробовал удаление соединения с сервером с обоих НМС, а потом подключение заново… Главное, знать пароль для подключения.

  • #16719

    Sever
    Участник

    Что показывает lssysconn -r all с обеих консолей?
    Попутно хочется взглянуть на lshmc -n

  • #16725

    DanGer
    Участник

    [spoiler][code]hscroot@localhost:~> lssysconn -r all
    resource_type=sys,type_model_serial_num=9117-570*NODE2,sp=primary,sp_phys_loc=U7879.001.DQD435G-P1-C8,ipaddr=10.159.20.111,alt_ipaddr=unavailable,state=Connected
    resource_type=sys,type_model_serial_num=9117-570*NODE2,sp=unavailable,sp_phys_loc=unavailable,ipaddr=192.168.2.201,alt_ipaddr=unavailable,state=Connecting,connection_error_code=Connecting 0000-0000-00000000
    resource_type=sys,type_model_serial_num=9117-570*NODE1,sp=primary,sp_phys_loc=U7879.001.DQD446Z-P1-C8,ipaddr=10.159.20.112,alt_ipaddr=unavailable,state=Connected
    resource_type=sys,type_model_serial_num=9133-55A*TEST,sp=primary,sp_phys_loc=unavailable,ipaddr=10.159.20.113,alt_ipaddr=unavailable,state=Connected

    hscroot@localhost:~> lshmc -n
    hostname=localhost,domain=localdomain,»ipaddr=10.159.20.101,10.1.255.1″,»networkmask=255.255.255.0,255.255.255.0″,gateway=10.159.20.1,nameserver=,domainsuffix=,slipipaddr=10.253.0.1,slipnetmask=255.255.0.0,ipaddrlpar=10.159.20.101,networkmasklpar=255.255.255.0,clients=,ipv6addrlpar=fe80:0:0:0:21a:64ff:fe95:5600,ipv4addr_eth0=10.159.20.101,ipv4netmask_eth0=255.255.255.0,ipv4dhcp_eth0=off,ipv6addr_eth0=fe80:0:0:0:21a:64ff:fe95:5600/64,ipv6auto_eth0=off,ipv6privacy_eth0=off,ipv6dhcp_eth0=off,lparcomm_eth0=on,speed_eth0=auto,duplex_eth0=auto,ipv4addr_eth1=10.1.255.1,ipv4netmask_eth1=255.255.255.0,ipv4dhcp_eth1=off,ipv6addr_eth1=,ipv6auto_eth1=off,ipv6privacy_eth1=off,ipv6dhcp_eth1=off,lparcomm_eth1=off,speed_eth1=auto,duplex_eth1=auto[/code][/spoiler]

    Со второго HMC точно такой же вывод, окромя строки с адресом 192.168.2.201. И адрес второго HMC заканчивается на 201.

  • #16726

    DanGer
    Участник

    Пожалуй, я бы испробовал удаление соединения с сервером с обоих НМС, а потом подключение заново… Главное, знать пароль для подключения.

    Пытался, тщетно.

  • #16730

    Sever
    Участник

    1. Кто выдает ip адреса в этой подсети?
    2. Откуда взялся левый коннект на 192.168.2.201? Его надо удалить… rmsysconn —ip 192.168.2.201 -o remove
    3. Почему консолям не назначены имена? Как вы их различаете? Как их различают сервисные процессоры?
    4. Сколько у вас сервисных процессоров на 570ых машинах?

  • #16734

    DanGer
    Участник

    1. IP статичные, вбил я.
    2. Это от старого конфига, во время установки так настраивали.
    3. Даже не знаю. Нигде каких-либо требований не было, я и не стал заморачиваться. Различаю по адресам — у меня не так уж и много консолей. В основном пользовался одной консолью, изредка поглядывал на второй (чтоб не «заржавел»). Как различают сервисные процессоры — даже понятия не имею.
    4. На каждой по одной.

  • #16735

    Sever
    Участник

    Топология мне не нравится.
    Дайте консолям хотя бы вменяемые уникальные имена, пропишите домен и укажите корректный адрес DNS.
    Пропишите их в DNS.
    Перегрузите.

  • #16736

    DanGer
    Участник

    Проблема не в сети. До этого точно с такими же параметрами все работало.
    Имена консолям я дам, но вот с остальным проблема — ни контролер домена, ни днс-сервер недоступны в этой подсети. И я с этим более чем согласен. Мне не нужно, чтобы куча народу шастали в этой сети.

  • #16737

    Oldnick
    Участник

    у HMC для нормальной ее работы должно быть имя. имя домена можете указать любое.
    DNS не обязателен, он нужен только для того чтобы из HMC-Gui вы смогли подлкючаться по имени с другой hmc или делать пинги по имени.
    тем более у вас это изолированный сегмент сети.

  • #16739

    DanGer
    Участник

    Сменил имена HMC.
    Как я и был уверен ранее, ничего не изменилось, кроме того, что я теперь счастливый обладатель возможности обновить прошивку сервера (аве муа!) :).
    Видимо, никто не сталкивался с такой проблемой.

    Все равно спасибо всем,кто проявил интерес.

  • #16740

    Michael
    Участник

    Если очень хочется что-то еще поделать:
    1. Взять и прочитать журнал «Системный администратор» за этот год, там начиная где-то с 3-го номера идёт серия статей про AIX, HMC в виртуалке и т. д.
    2. Поставить свеженькую НМС 7.7.5 в виртуалку
    3. Убить соединение с проблемным сервером на одной из НМС.
    4. Создать соединение с проблемным сервером на НМС 7.7.5 и посмотреть, заработает ли там…

  • #16741

    Sever
    Участник

    Попутно можно поизучать как ведут себя две консоли и сервера в изолированной сети.
    Классический ботнет от IBM , консоли должны постоянно искать выход наружу в поисках сервисного центра, который является управляющей точкой вашего миниботнета.

  • #16743

    andrewk
    Участник

    Danger, Вам уже отвечали — обновите микрокод. Я могу еще посоветовать сделать reset сервис-процессору. Виртуальный терминал — это фактически сетевое соединение между HMC и сервис-процессором сервера. Если он не открывается, то с высокой долей вероятности я могу предположить проблемы в этом соединении. И sever Вам правильно пишет — tcpdump в зубы и ищите, где что пропадает, либо не так посылается.

Для ответа в этой теме необходимо авторизоваться.