Subsystem could not be started


Главная Форумы POWER Systems AIX/Hardware Subsystem could not be started

В этой теме 13 ответов, 5 участников, последнее обновление  Дмитрий 7 года/лет, 8 мес. назад.

  • Автор
    Сообщения
  • #8069

    Павел
    Участник

    Доброго времени суток всем!
    AIX 6.1
    Вот такая ерунда после плановой перезагрузки сервера.
    Подскажите в чем может быть причина и как это исправить?
    До файловой системы через putty естественно достучатся не можем 🙁

    Successfully updated the Kernel Role Table.
    Successfully updated the Kernel Command Table.
    Successfully updated the Kernel Device Table.
    OPERATIONAL MODE Security Flags
    ROOT : ENABLED
    TRACEAUTH : DISABLED
    System runtime mode is now OPERATIONAL MODE.
    Setting tunable parameters…complete
    Starting Multi-user Initialization
    Performing auto-varyon of Volume Groups
    Activating all paging spaces
    swapon: Paging device /dev/hd6 is already active.
    The current volume is: /dev/hd1
    Primary superblock is valid.
    The current volume is: /dev/hd10opt
    Primary superblock is valid.
    Performing all automatic mounts
    Replaying log for /dev/fslv00.
    Multi-user initialization completed
    Checking for srcmstr active…complete
    Starting tcpip daemons:
    0513-012 The syslogd Subsystem could not be started.
    The Subsystem’s user id could not be established.
    Please check the Subsystem’s user id and try again.
    0513-012 The sendmail Subsystem could not be started.
    The Subsystem’s user id could not be established.
    Please check the Subsystem’s user id and try again.
    0513-012 The portmap Subsystem could not be started.
    The Subsystem’s user id could not be established.
    Please check the Subsystem’s user id and try again.
    0513-012 The inetd Subsystem could not be started.
    The Subsystem’s user id could not be established.
    Please check the Subsystem’s user id and try again.
    0513-012 The snmpd Subsystem could not be started.
    The Subsystem’s user id could not be established.
    Please check the Subsystem’s user id and try again.
    0513-012 The hostmibd Subsystem could not be started.
    The Subsystem’s user id could not be established.
    Please check the Subsystem’s user id and try again.
    0513-012 The snmpmibd Subsystem could not be started.
    The Subsystem’s user id could not be established.
    Please check the Subsystem’s user id and try again.
    0513-012 The aixmibd Subsystem could not be started.
    The Subsystem’s user id could not be established.

    AIX Version 6
    Copyright IBM Corporation, 1982, 2009.
    Console login:

    0513-012 The ctrmc Subsystem could not be started.
    The Subsystem’s user id could not be established.
    Please check the Subsystem’s user id and try again.
    Nim_master: Connection timed out
    0042-001 nimclient: processing error encountered on «master»:
    0042-006 nimclient: (To_Master) rcmd Connection timed out

  • #8070

    uxTuaHgp
    Участник

    У вас что по сети загрузка?
    В консоли тоже не дает логиниться? Понятно что ssh не дает — все сервисы отказались пускаться.

  • #8071

    Michael
    Участник

    С сетевой платой на сервере всё нормально? Она, случайно, не disabled?

  • #8073

    Павел
    Участник

    В том то и проблема что не по сети грузится.
    к Nim — серверу он подключается только для обновлений.
    Вот ещё что удалось нарыть, сделали диагностику

    PREVIOUSLY REPORTED PROBLEMS 801018

    The Service Request Number(s)/Probable Cause(s)
    (causes are listed in descending order of probability):

    BA09000B: Platform Firmware Unrecovered Error, bypassed with loss of
    function. Refer to the system service documentation for more
    information.
    Additional Words: 2-00000000 3-00000000 4-00000000 5-00000000
    6-00000000 7-00000000 8-00000000 9-00000000
    Error log information:
    Date: Fri May 14 11:22:12 GMT+03:00 2010
    Sequence number: 55
    Label: SCAN_ERROR_CHRP
    Priority: H FRU: n/a S/N: n/a CCIN: n/a Location:
    U7778.23X.106A7BA-V2-C2-T1-L8100000000000000

  • #8074

    Павел
    Участник

    в консоли тоже не логинится,
    вроде показывает приветствие AIX 6 и тп, но при вводе логина и пароля пишет что login invalid

  • #8076

    andrewk
    Участник

    тяжелый случай. перегружайтесь в Maintenance Mode и, если оно там позволяет, — usrck/grpck или просто ручками проверьте всякие /etc/passwd, /etc/security/passwd, …

  • #8080

    Павел
    Участник

    Уф на сегодня пока всё оставил как есть, счас дома, спасибо вам ребят что пытаетесь помочь.
    Сейчас могу написать более подробно что случилось, но пока проблему так и не решил.
    Завтра буду пробовать в Maintance mode восстановить, благо сервер не критичный только готовил его для того чтобы переносить на него реальную базу, на крайний случай поставлю всё заново.
    Значит делал я вот что — поставил мускуль, php, развернул дамп реальной базы, настроил репликацию на реальный сервак с базой. Хотел поставить и настроить самбу, самбу поставил, в конфигах всё как надо прописал, пытаюсь запустить smbd — результата — 0, ps -Af | grep smb ничего не показывает, но тут случилось что-то непонятное, перестало пускать по фтп ( что — то типа «для этого юзера нельзя по фтп» точно не помню, номер ошибки 530), хотя никаких связанных файлов с доступом по фтп не трогал. Стал перегружать, перезагрузился нормально, точнее я не смотрел логи загрузки, потом только заметил что демон ftpd не стартован, пробовал руками запустить — тоже нет, и так же с самбой… полез в IVM (Web консоль) не грузиться, думаю что за фихня, полез на VIO через putty рестартанул его все нормально, стала грузиться Web консоль, потом думаю может проблемы из-за того что я поставил bash вместо стандартного ksh (так подумалось, типа может чего лишнего задел:laugh: ), поменял в конфиге назад на ksh перезагрузил и вот тут такое :S

    Ещё вспомнил, было, когда первый раз перегружал, система очень долго поднималась минут 15 наверное… И ещё когда мускуль пытался запустить он ругался на нехватку памяти, пришлось применить ulimit :blush:

    P.S. наверное это надо было написать первым постом:)

  • #8082

    Павел
    Участник

    mih писал(а):

    С сетевой платой на сервере всё нормально? Она, случайно, не disabled?

    Я просто немного в спешке написал и не подробно, с сетевухой все нормально, у нас дело в том что блейды порезаны на lpar-ы и всё так сказать на виртуальном уровне:S
    дело в том, что это я проверил первым делом, что самое интересное, после всех этих ошибок в протоколе загрузки, адрес сервера даже пингуется, и VIO говорит , ну переводя на человеческий язык:laugh: — что ip присвоен сетевому интерфейсу, но вот статус монтирования чего-то там (завтра напишу) остается не активен, тогда как соседний lpar ( второй сервак который настроен на бэкапы) работает прекрасно и остается активным :huh:

  • #8083

    Павел
    Участник

    andrewk писал(а):

    тяжелый случай. перегружайтесь в Maintenance Mode и, если оно там позволяет, — usrck/grpck или просто ручками проверьте всякие /etc/passwd, /etc/security/passwd, …

    Ещё момент такой, пробовал загрузиться в Single user mode через F5, говорит что не может прочесть файл /etc/passwd ( что-то типа что записи по пользователю ROOT или какие-то ещё там в этом файле не найдены) и предлагает загрузится в разных режимах типа от 0 до 9 и всякие другие, вобщем в незарезервированных режимах 2 и 3 загрузится не удалось, в остальных пробовать не стал… рабочий день закончился:lol:

  • #8125

    Павел
    Участник

    Всем привет!

    Вобщем проблему решил, как посоветовал andrewk, полез смотреть файлы /etc/passwd и /etc/security/passwd и вот почему-то файл /etc/passwd оказался пустой, кто знает, может причиной тому было редактирование этого файла в редакторе mc, может ещё что-то но факт в том что он просто оказался пустой, после восстановления его содержимого система загрузилась нормально.
    Всем спасибо за внимание!:)

  • #8126

    andrewk
    Участник

    я люблю mc! 😀 выкиньте это поделие вендофила с сервера и никогда им не пользуйтесь

  • #8131

    Michael
    Участник

    Найдено на bash.org.ru:

    Bula: не, ну он вообще умный хлопец — чтоб потренироваться в vi выбрал файл rc.conf

    Так что я бы не стал сильно хаять МС: очень многое зависит еще и от того, кто и как его применяет.

  • #8133

    uxTuaHgp
    Участник

    Когда-то на курсах по OpenVMS я спросил у тренера: а нет ли под ВМС деко или миднайта?
    А он мне ответил: А зачем, шелл же очень удобный.
    :laugh:

  • #8138

    Дмитрий
    Участник

    (тема в оффтопик пошла).
    На курсах по одной замечательной ОС одного замечательного вендора (курсы по администрированию) слушатели регулярно запарывали /etc/inittab.
    Что выяснилось методом дедукции и случайного (пришлось однажды) внимательного чтения лабораторок:
    В одном из заданий слушателей просили куда-то скопировать этот файл и в ответах к лабам была команда cp /etc/inittab … (точный синтаксис не помню).
    А слушатели (не в обиду им будет сказано) частенько попадали на этот курс с нулевым опытом работы в UNIX и командной строке. Лабу делали по ответам, и даже не осознавали, что произошло.

Для ответа в этой теме необходимо авторизоваться.