vios 2.2 где он?


В этой теме 19 ответов, 4 участника, последнее обновление  andrewk 7 года/лет назад.

  • Автор
    Сообщения
  • #9531

    Вадим
    Участник

    искал самые новые патчи на фикс централе и обнаружил интересную вещь, появилась версия виоса 2.2.0.10 а вот никаких миграционных пакетов, или такого виоса нигде более не нашел, может я просто не там искал?

  • #9534

    andrewk
    Участник

    не торопитесь. Скорее всего он скоро выйдет — поэтому и появился на фиксцентрале. Вообще же, насколько я помню, он должен был выйти не раньше октября — вместе с AIX 7.1.

  • #9557

    Вадим
    Участник

    обновил до этой версии один из тестовых серверов
    и теперь при входе от padmin пишет веселую вещь
    exec(): 0509-036 Cannot load program ioscli because of the following errors:
    0509-022 Cannot load module /usr/lib/libvio.a(shr.o).
    0509-150 Dependent module libsolidodbc.a(odbc.so) could not be loaded.
    0509-022 Cannot load module libsolidodbc.a(odbc.so).
    0509-026 System error: A file or directory in the path name does not exist.
    0509-022 Cannot load module ioscli.
    0509-150 Dependent module /usr/lib/libvio.a(shr.o) could not be loaded.
    0509-022 Cannot load module .
    exec(): 0509-036 Cannot load program ioscli because of the following errors:
    0509-022 Cannot load module /usr/lib/libvio.a(shr.o).
    0509-150 Dependent module libsolidodbc.a(odbc.so) could not be loaded.
    0509-022 Cannot load module libsolidodbc.a(odbc.so).
    0509-026 System error: A file or directory in the path name does not exist.
    0509-022 Cannot load module ioscli.
    0509-150 Dependent module /usr/lib/libvio.a(shr.o) could not be loaded.
    0509-022 Cannot load module .
    глянул от рута, нету такой библиотеки libsolidodbc.a

  • #9558

    Артем
    Участник

    Еще тут появился как Fix Pack 24
    http://www14.software.ibm.com/webapp/set2/sas/f/vios/download/home.html

  • #9559

    andrewk
    Участник

    Каким образом Вы обновляли? С помощью Migration DVD или фикспака?

  • #9560

    Вадим
    Участник

    с помощью фикс пака, в принципе я понял в чем проблема
    в том что включился RBAC, и соответсвенно я не могу от padmin ничего выполнить тк вылетают такие сообщения, и пользователь положенных прав ему не получает, думаю временно как то нада отключить рбак и наслаждаться до следующего фикса

  • #9561

    andrewk
    Участник

    swrole — PAdmin

  • #9562

    Вадим
    Участник

    от рута
    # swrole — PAdmin
    swrole: 1420-052 PAdmin is not a valid role for root.

    от падмина
    exec(): 0509-036 Cannot load program ioscli because of the following errors:
    0509-022 Cannot load module /usr/lib/libvio.a(shr.o).
    0509-150 Dependent module libsolidodbc.a(odbc.so) could not be loaded.
    0509-022 Cannot load module libsolidodbc.a(odbc.so).
    0509-026 System error: A file or directory in the path name does not exist.
    0509-022 Cannot load module ioscli.
    0509-150 Dependent module /usr/lib/libvio.a(shr.o) could not be loaded.
    0509-022 Cannot load module .
    exec(): 0509-036 Cannot load program ioscli because of the following errors:
    0509-022 Cannot load module /usr/lib/libvio.a(shr.o).
    0509-150 Dependent module libsolidodbc.a(odbc.so) could not be loaded.
    0509-022 Cannot load module libsolidodbc.a(odbc.so).
    0509-026 System error: A file or directory in the path name does not exist.
    0509-022 Cannot load module ioscli.
    0509-150 Dependent module /usr/lib/libvio.a(shr.o) could not be loaded.
    0509-022 Cannot load module .
    $ swrole — PAdmin
    padmin’s Password:
    exec(): 0509-036 Cannot load program ioscli because of the following errors:
    0509-022 Cannot load module /usr/lib/libvio.a(shr.o).
    0509-150 Dependent module libsolidodbc.a(odbc.so) could not be loaded.
    0509-022 Cannot load module libsolidodbc.a(odbc.so).
    0509-026 System error: A file or directory in the path name does not exist.
    0509-022 Cannot load module ioscli.
    0509-150 Dependent module /usr/lib/libvio.a(shr.o) could not be loaded.
    0509-022 Cannot load module .
    exec(): 0509-036 Cannot load program ioscli because of the following errors:
    0509-022 Cannot load module /usr/lib/libvio.a(shr.o).
    0509-150 Dependent module libsolidodbc.a(odbc.so) could not be loaded.
    0509-022 Cannot load module libsolidodbc.a(odbc.so).
    0509-026 System error: A file or directory in the path name does not exist.
    0509-022 Cannot load module ioscli.
    0509-150 Dependent module /usr/lib/libvio.a(shr.o) could not be loaded.
    0509-022 Cannot load module .
    $

  • #9563

    andrewk
    Участник

    попробуйте переустановить фикспак, если Вы его еще не закоммитили. что-то у Вас недоустановилось.

    updateios -reject
    updateios -dev /path/to/FP -install -accept

    команда swrole — PAdmin должна даваться из-под padmin’а. Из-под root’a, чтобы отключить RBAC, можете попробовать сказать:

    chdev -l sys0 -a Enhanced_RBAC=false

    после этого надо перезагрузить систему.

  • #9564

    Вадим
    Участник

    updateios -reject
    updateios -dev /path/to/FP -install -accept
    не прошло, ошибка едентичная предыдущей

    пробуем отключить расширенный рбак

  • #9565

    Вадим
    Участник

    после ребута, все равно при попытке зайти от padmin та же ошибка
    ну и собственно ниодна команда padmin(а) не работает 🙁

  • #9566

    andrewk
    Участник

    попробуйте из-под рута найти все пакеты, которые относятся к FP24 и находятся в состоянии APPLIED, и для каждого пакета — installp -r

  • #9567

    Вадим
    Участник

    да если чесно окно обслуживания достаточно большое, похоже просто в пакет обновления забыли включить данную либку или комплект либок
    может стоит подождать
    запрос с глубоким огорчением и возмущением конечно в ИБМ уже заслал будем ждать 😀 глядишь и новый фиксик выйдет

  • #9568

    Вадим
    Участник

    а все оказалось несколько хуже 🙂 тк нету контракта на саппорт виоса :-(, чтото мне подсказывает что это почти аикс и контракта на поддержку аикса должно хватить, но пока не понятно

  • #9569

    andrewk
    Участник

    хоть VIOS изнутри и AIX, но контракт на него должен быть отдельный. Самый быстрый способ решения проблемы — переустановка VIOS’а, тем более, что он тестовый 😉
    я смогу у себя где-нибудь попробовать накатить фикспак не раньше конца недели, чтобы проверить, будет ли у меня такая же ошибка.

  • #9571

    Вадим
    Участник

    как бы сказать тестовый он временно тестовый, забрал из продакшена на пару недель (если точнее быть то до 27 сентября) как раз для проверки и до установки обновлений
    попробовал smitty update_all доустновился только 1 пакет Java6.sdk 6.0.0.215 (оно не то что мне есть нужно)
    а переустановить, идея конечно хорошая, но боюсь не сразу смогу все собрать как должно быть 🙂

  • #9580

    Вадим
    Участник

    решение найдено 🙂

    1.на другой машине обновляем виос до нужного сервис пака
    2. копируем недостающие библиотеки и делаем на них симлинки (как на машине доноре, в моем случае это 2 библиотеки libcluster.a libsolidodbc.a, в общем случае число может быть и большим и меньшим или совсем другим)
    3. получаем выполенение всех команд без проблем
    4. накатываем апдейт повторно, уже от пользователя padmin
    5. выполняем все требуемые команды
    6. после перезагрузки получаем рабочую систему

  • #9752

    andrewk
    Участник

    «конец недели» пришел вчера — обновил первые два VIOS’а с FP23 на FP24. Все прошло без проблем, с небольшим отклонением от инструкции — я license -accept до ребута писал, а не после 🙂 Кроме того заметно улучшилась жизнь коллег-бэкаперов — все драйвы, розданные через NPIV, вдруг обнраужились в клиентских LPAR’ах и начали работать. Поэтому могу лишь рекомендовать устанавливать это фикспак для тех, кто раздает ленты через NPIV.

  • #10390

    Aleksey
    Участник

    Приветствую.

    Обновил тут виос до версии 2.2.0.10-FP-24
    В инструкции пишут
    If you are upgrading to Fix Pack 24 from VIOS level 2.1.3, run the following command
    $ swrole — PAdmin
    $ shutdown -restart
    Я с 2.1.3 и обновлял.
    Перезагружаюсь, а мне пишут Access to run command is not valid и так при всех последующих логинах и ребутах. Выполнять команды можно только предварительно выполнив swrole — PAdmin.
    Как от этого можно избавиться ?

  • #10391

    andrewk
    Участник

    у меня такое писало только до ребута. После ребута — все ок.

Для ответа в этой теме необходимо авторизоваться.