Ответ в теме: downgrade AIX

Главная Форумы POWER Systems downgrade AIX Ответ в теме: downgrade AIX

#44519

Дмитрий
Участник

Станислав, если предположить, что Заказчику конкретный TL-SP нужен не для “галочки”, то что подменить команду oslevel, что снести пару пакетов (как я выше предложил) – положительного результата не даст.
Если ПО совместимо с определённой версией системной библиотеки, а с более новой – нет, то работать такое ПО не будет, что-бы там oslevel не показывал.

Вопрос, что это за ПО такое? Если это какой-то legacy и без него никак, то увы. Придётся как-то даунгрейдить.
Но более правильный вариант – обновить это самое ПО на более свежую версию. Она должна быть совместима со свежим AIX-ом (вообще слово AIX здесь можно на название любой другой ОС заменить).

И Заказчику нужно объяснить, что AIX 71-03-04 давно уже не поддерживается. 71-03-05 тоже скоро сойдёт с экранов. Под него ещё полгода назад с большой неохотой фиксы выпускали, приходилось настаивать. Для AIX 7.1 актуальный TL 03 вообще весь уже устарел.

Заметьте, я не пишу, что срочно надо обновляться на  AIX 7.2.

Итого самый правильный выход – понять, откуда у Заказчика взялись такие требования.