Недоступность сети и LHEA

Главная Форумы POWER Systems AIX/Hardware Недоступность сети и LHEA

Просмотр 10 веток ответов
  • Автор
    Сообщения
    • #17699
      Григорий
      Участник

      Доброго времени суток всем

      Второй раз возникает одна и та же проблема… Правда первый раз ее кое-как решить удалось, а в этот раз – не получается.

      Итак, имеется сервер с двумя адаптерами IVE.
      В каждом адаптере 4 порта: 2x1GbE, 2x10GbE
      На сервере сделано энное кол-во LPAR.
      3 из них должны выходить в сеть через один и тот же физ. порт 10GbE c IVE
      1 LPAR – AIX 7.1 c с последним TL, SP
      2 LPAR – RHEL ppc64
      3 LPAR – RHEL ppc64
      Все отлично работает.
      Теперь решили на 2 и 3 LPAR поставить AIX.
      Ставим AIX на 2 – настраиваем сетевые параметры, сеть доступна, пинги идут, все хорошо.
      Ставим AIX на 3 – настраиваем сетевые параметры и тут начинается непонятное.

      ifconfig показывает, что интерфейс поднят
      entstat показывает, что пакеты принимаются и отправляются
      errpt показывает, что проблем с физ. адаптерами нет
      tcpdump показывает, что хост отправляет arp-пакеты, ищет шлюз

      Тем не менее сам хост не пингует ни шлюз, ни кого бы то ни было в этой сети. Сам на пинги тоже не отвечает.

      В прошлый раз единственное, что помогло – удаление и пересоздание LPAR c идентичным профайлом.
      В этот раз даже это не помогло.

      Подскажите, куда копать, что проверять?

    • #17700
      Olegg
      Участник

      Здравствуйте.

      При схожих глюках в Ethernet на логических разделах мне помолало такое шаманство – скопировать профайл раздела в другое имя. Сделать новый профайл основным по умолчанию, стартовать с него раздел.

    • #17702
      Григорий
      Участник

      Пробовал и такой вариант тоже. Правда, новый профайл не делал дефолтным, а просто стартовал раздел с него.

      Сейчас при исследовании всего и вся и сравнении с работающими LPAR заметил такую вещь:
      entstat показывает
      Promiscuous Mode: (QP 322)/On
      При этом на HMC для этого порта Promiscuous LPAR установлена None

      Колдовство, не иначе…

    • #17703
      Oldnick
      Участник

      какой сервер и версия прошивки?

    • #17704
      Григорий
      Участник

      Сервер 9117-MMB, версия прошивки 01AM730_95

    • #17761

      А там у вас 802.3ad режим у бондинга не случился случайно? LHEA не умеет такое переваривать.

    • #17769
      Григорий
      Участник

      802.3ad включено на других LPAR, которым отданы выделенные порты IVE. Другие LPAR эти порты не используют.

      Провел вот такой эксперимент:
      В LPAR отдан (условно говоря) 1-ый логический порт 1-го физического порта IVE.
      Настраиваем на соответствующем интерфейсе сетевые параметры, проверяем пинг – не идет
      Отдаем в LPAR (условно говоря) 1-ый порт 2-го физического порта IVE
      Настраиваем на соответствующем интрефейсе те же самые сетевые параметры, проверяем пинг – не идет

      Интерфейсу, который настраивали первым говорим ifconfig detach, проверяем пинг – получаем ответ, что заданная сеть недоступна
      Перестартовываем сетевые службы, проверяем пинг – пинги пошли
      Выключаем LPAR, удаляем из профайла 1-ый логический порт, стартуем LPAR, проверяем пинг – пинг не идет

      Еще несколькими экспериментами удалось выяснить, что если в системе два интерфейса с одинаковыми параметрами, то различными комбинациями действий по опусканию одного и поднятию другого хоть один из них можно заставить работать.

      Буду благодарен за идеи и другие варианты экспериментов 🙂

    • #17799
      Olegg
      Участник

      Доброе утро.
      У Вас в разделах не включен “Active memory expansion” и “Active memory sharing”?
      С ними LHEA не работает…

    • #19414
      terminus
      Участник

      Была аналогичная проблема:
      https://www.aixportal.ru/forum/11–power/13588—lhea—–aix.html

      По данной проблеме был открыт PMR который еще не имеет официального решения.

      Неофициальное решение – или перезапустить целиком весь Power сервер (выключение питания) или инициальзировать дамп для проблемной LPAR.

    • #19418
      Oleg
      Участник

      802.3ad включено на других LPAR, которым отданы выделенные порты IVE. Другие LPAR эти порты не используют.

      это на хосте, а на eth-коммутаторе?

      P.S. не обратил внимания на дату 🙂
      от археологи 🙂

    • #20006
      terminus
      Участник
Просмотр 10 веток ответов
  • Для ответа в этой теме необходимо авторизоваться.