Не запускается ssh на AIX 5.3


Главная Форумы POWER Systems AIX/Hardware Не запускается ssh на AIX 5.3

В этой теме 12 ответов, 6 участников, последнее обновление  Дмитрий 8 года/лет, 11 мес. назад.

  • Автор
    Сообщения
  • #3521

    Ахмед
    Участник

    Добрый день!

    У меня следующая проблема.

    Не запускается sshd когда стартую в ручную.

    В errpt вываливается следующая ругань:

    —————————————————————————
    LABEL: SRC_TRYX
    IDENTIFIER: 1BA7DF4E

    Date/Time: Fri May 15 11:24:32 WDT 2009
    Sequence Number: 4730
    Machine Id: 005255CA4C00
    Node Id: DB2
    Class: S
    Type: PERM
    Resource Name: SRC

    Description
    SOFTWARE PROGRAM ERROR

    Probable Causes
    APPLICATION PROGRAM

    Failure Causes
    SOFTWARE PROGRAM

    Recommended Actions
    DETERMINE WHY SUBSYSTEM CANNOT RESTART

    Detail Data
    SYMPTOM CODE
    256
    SOFTWARE ERROR CODE
    -9020
    ERROR CODE
    0
    DETECTING MODULE
    ‘srchevn.c’@line:’343’
    FAILING MODULE
    sshd
    —————————————————————————
    LABEL: SRC_RSTRT
    IDENTIFIER: BA431EB7

    Date/Time: Fri May 15 11:24:32 WDT 2009
    Sequence Number: 4729
    Machine Id: 005255CA4C00
    Node Id: DB2
    Class: S
    Type: PERM
    Resource Name: SRC

    Description
    SOFTWARE PROGRAM ERROR

    Probable Causes
    APPLICATION PROGRAM

    Failure Causes
    SOFTWARE PROGRAM

    Recommended Actions
    VERIFY SUBSYSTEM RESTARTED AUTOMATICALLY

    Detail Data
    SYMPTOM CODE
    256
    SOFTWARE ERROR CODE
    -9035
    ERROR CODE
    0
    DETECTING MODULE
    ‘srchevn.c’@line:’217’
    FAILING MODULE
    sshd
    —————————————————————————
    LABEL: SRC_RSTRT
    IDENTIFIER: BA431EB7

    Date/Time: Fri May 15 11:24:32 WDT 2009
    Sequence Number: 4728
    Machine Id: 005255CA4C00
    Node Id: DB2
    Class: S
    Type: PERM
    Resource Name: SRC

    Description
    SOFTWARE PROGRAM ERROR

    Probable Causes
    APPLICATION PROGRAM

    Failure Causes
    SOFTWARE PROGRAM

    Recommended Actions
    VERIFY SUBSYSTEM RESTARTED AUTOMATICALLY

    Detail Data
    SYMPTOM CODE
    256
    SOFTWARE ERROR CODE
    -9035
    ERROR CODE
    0
    DETECTING MODULE
    ‘srchevn.c’@line:’217’
    FAILING MODULE
    sshd

    В чем может быть дело?

    Я в AIX-е новичок:unsure:

  • #3522

    kir
    Хранитель

    А как стартуешь?

  • #3525

    Дмитрий
    Участник

    В errlog софтверные ошибки неинформативны.
    Настройте syslogd и посмотрите там.

    Если нужна помощь по syslogd (такой-же, как в других Unix, рестарт: refresh -s syslogd), пишите!

  • #3526

    _KIRill
    Хранитель

    akovalev писал(а):

    А как стартуешь?

    Присоединяюсь к вопросу. startsrc?

    ---As If, But Not---

  • #3527

    byldozer
    Участник

    Что-то похожее было и у меня, я тогда обновил пакет openssl.9.8.600 до openssl.9.8.801, откат на предыдущую версию помог.
    Хотя нет, он там четко ругался на несовместимость версий.

  • #3538

    Ахмед
    Участник

    запускаю из под Smitty (startsrc -s’sshd’ )

    После запуска появляетсся сообщение:

    0513-059 The sshd Subsystem has been started. Subsystem PID is 213364

    Но,когда просматриваю список запущенных сервисов ( Smitty-> Processes & Subsystems->Subsystems->List All Subsystems),вижу такое:

    Subsystem Group Status
    sshd ssh inoperative

    И в errpt вышеуказанная ругань

    Может sshd нужно запустить с какими-то параметрами?

  • #3539

    byldozer
    Участник

    Sshd хоть раз стартовал на этой машине или нет ???
    И дай пожалуйста версии openssl и openssh.

  • #3540

    Ахмед
    Участник

    Openssh 3.4.0.0

    Openssl не установлен.

    Попробую скачать и установить, позже отпишусь

  • #3541

    andrewk
    Участник

    1. openssh без openssl не работает.
    2. а может быть что-нибудь поновее запустить? уже есть 5.0 afair.

  • #3542

    byldozer
    Участник

    Поставь Openssl и будет счастье. Должно все работать, только ставь с того диска с которого ставился openssh, дабы избещать несовметимости версий.

  • #3603

    Дмитрий
    Участник

    Да, OpenSSH почему-то не пишет в списке реквизитов, что ему нужен OpenSSL. Может, по принципу: “Если ты такой тупой. что сам не догадался, то не нужен тебе ssh” 🙁

    OpenSSL, по-моему, на другом диске.
    Ищите на Expansion Pack CD или Linux Toolbox.
    А лучше сходите на сайт IBM и скачайте оттуда (точнее, оттуда будет ссылка) версии посвежее.

    Насколько я помню, если поставить сначала OpenSSH, то, чтобы всё заработало, лучше его сначала удалить, поставть OpenSSL и заново поставить OpenSSH.


    Кстати, вопрос offtopic:
    Регулярно натыкался на такую фигню:
    Ставлю какие-то линуксовые пакеты, из них часть есть в формате rpm, а часть – installp.
    Если по логике работы, то у меня в руках полный набор реквизитов, все условия выполнены.
    А если по логике придурошного инсталлера, то он мне пишет: “не установлена у тебя такая-то библиотека (installp), иди лесом!”
    Конечно, можно всё самому скомпилять, но это “в лом”, понятное дело.

    Кто как эту проблему решал?

  • #3620

    andrewk
    Участник

    openssh при инсталляции требует openssl и без него не ставиться. в 6.1 afair openssl уже идет в формате installp, хотя могу ошибаться.

  • #3638

    Дмитрий
    Участник

    andrewk, старые версии из комплекта Linux Toolbox + Exp. Pack не требовали. Это точно.

Для ответа в этой теме необходимо авторизоваться.