Обновление AIX (TL)

Главная Форумы POWER Systems AIX/Hardware Обновление AIX (TL)

Просмотр 11 веток ответов
  • Автор
    Сообщения
    • #13004
      Anton Bukhman
      Участник

      Приветствую, уважаемые!
      Рад, что aixportal снова работает 🙂

      Есть вопрос(до сих пор чайник):
      есть IBM p570. на нём AIX 5300-05-00.
      Нужно обновить TL(Для IBM Systems Director 6.2.1)
      Решил сразу до 12.
      Скопировал aix5300-TL12-00 в деректорию, через smitty-установку увидил.
      Дальше очевидно была ошибка. Выбрал все bos.*, оно вроде обновилось, но после установки и перезагрузки oslevel -s показал 5300-05-00-00(помоему так). Дальше ничего не устанавливалось, из бэкапа не востанавливлось. Переустановил систему с нуля.
      Теперь собственно вопросы:
      1.Как правильно обновить TL
      2.Уже позже прочитал здесь про повторный накат обновлений и всё ок.
      3.Что я делаю не так?

      P.S. Прошу не судить строго, учусь-исправляюсь.
      В понидельник поеду на курсы в IBM 🙂

    • #13006
      andrewk
      Участник

      1. прочитать README
      2. smitty update_all, выбрать каталог, куда были скачены все апдейты, поставить COMMIT = false, нажать Enter
      3. попить кофе
      4. перезагрузить сервер

    • #13007
      Anton Bukhman
      Участник

      При обновлении выдал(в конце)
      installp: * * * A T T E N T I O N ! ! !
      Software changes processed during this session require this system
      and any of its diskless/dataless clients to be rebooted in order
      for the changes to be made effective.
      Статус filed.
      oslevel -s 5300-05-CSP-0000

      🙁
      Может изза того, что не commit?

    • #13009
      Alex Kovalev
      Участник

      Текущий уровень может показывать даже если не обновилось 1-2 пакета из 600.
      При использовании ключей -r -l кажется покажет какиt пакеты необновлены, для того чтобы он считал себя TL12.
      Commit удаляет старые версии пакетов.
      Applied устанавливает новые пакеты и работает на новых, но старые не удаляет.
      В Applied можно откатиться до старых пакетов.

    • #13011
      andrewk
      Участник

      если статус failed – ищите в выводе команды, какие конкретно пакеты не обновились и почему

    • #13012
      Michael
      Участник

      Обсуждали уже: сначала делаем повторный накат обновлений и если oslevel опять показывает 5300-05-CSP-0000 берём compare_report оттуда, откуда скачивали обновления и начинаем разбираться…

    • #13013
      Anton Bukhman
      Участник

      Не установились 15 пакетов :

      FAILURES
      ——–
      Filesets listed in this section failed pre-installation verification
      and will not be installed.

      Requisite Failures
      ——————
      SELECTED FILESETS: The following is a list of filesets that you asked to
      install. They cannot be installed until all of their requisite filesets
      are also installed. See subsequent lists for details of requisites.

      #1 csm.client 1.7.1.0 # Cluster Systems Management C…
      #2 csm.core 1.7.1.0 # Cluster Systems Management Core
      #3 csm.deploy 1.7.1.0 # Cluster Systems Management D…
      #4 csm.diagnostics 1.7.1.0 # Cluster Systems Management P…
      #5 csm.dsh 1.7.1.0 # Cluster Systems Management Dsh
      #6 csm.gui.dcem 1.7.1.0 # Distributed Command Executio…
      #7 csm.msg.EN_US.core 1.7.0.0 # CSM Core Func Msgs – U.S. En…
      #8 devices.pci.1410c302.diag 5.3.10.0 # PCI-X266 Ext Tri-x4 3Gb SAS …
      #9 devices.pci.1410c302.rte 5.3.10.0 # PCI-X266 Ext Tri-x4 3Gb SAS …
      #10 devices.pci.1410c302.rte 5.3.11.0 # PCI-X266 Ext Tri-x4 3Gb SAS …
      #11 devices.pciex.14103903.diag 5.3.7.0 # PCI Express 3Gb SAS RAID Ada…
      #12 devices.pciex.14103903.diag 5.3.9.0 # PCI Express 3Gb SAS RAID Ada…
      #13 devices.pciex.14103903.rte 5.3.7.0 # PCI Express 3GB SAS RAID Ada…
      #14 devices.pciex.14103903.rte 5.3.11.0 # PCI Express 3GB SAS RAID Ada…
      #15 devices.pciex.14106803.diag 5.3.7.0 # 4-Port 10/100/1000 Base-TX P…

      До этого было 17. После повторного наката 2 установились.(bos)
      Система чистая была. Только ssh установлен был.
      Буду разбираться.

    • #13014
      Michael
      Участник

      Пакеты с 1-го по 7-й зависимы от наличия csm.server… Но, если Вы раньше спокойно жили без csm.server, то и сейчас без него проживёте.
      А эти пакеты csm.* можно просто почикать. :cheer:

      Насчёт devices ничего не скажу, не сталкивался.

    • #13015
      andrewk
      Участник

      почти все devices – это драйвера для SAS-устройств, которые afair в AIX 5.3 TL5 еще не поддерживались. В системе скорее всего не хватает базовых версий этих пакетов, поэтому они и не устанавливаются. С чего они вообще взялись устанавливаться – хз.

    • #13016
      Anton Bukhman
      Участник

      Хм.. Кластеры, SAS.. Может ли это быть из-за того, что DS’ка подключена?

    • #13020
      Michael
      Участник

      Я в логику ИБМ-ов стараюсь не вникать.

      Вот стоял у нас TL где-то примерно 8-й. Обновили до 12-го, но oslvel упорно жаловался, что он не выше 8-ки. Compare_report показал, что не обновились как раз csm.*
      Выяснилось, что раньше они у нас спокойно были установлены и так, а теперь им зачем-то потребовался еще csm.server, иначе обновления не накатывались.

      Снесли все имевшиеся csm.* нафиг – oslevel бодро отрапортовал, что мы попали сразу на 12-й TL 🙂

    • #13025
      Дмитрий
      Участник

      У меня была точно такая же ситуация. Старая система, досталась “в наследство”.
      Обновление в один приём не получается.

      Решение: сначала обновляемся до TL 09, потом до TL 12.
      В TL 09 появились новые пакеты, и для обновления на TL 12 нужно, чтобы они уже стояли.
      Обновлять только bos ни в коем случае нельзя, систему в такую позу поставите, из которой её вытащит только волшебный restore.

Просмотр 11 веток ответов
  • Для ответа в этой теме необходимо авторизоваться.