Падение скорости virtual LAN на Power7

Главная Форумы POWER Systems AIX/Hardware Падение скорости virtual LAN на Power7

Просмотр 9 веток ответов
  • Автор
    Сообщения
    • #15611
      Sergey Alexeev
      Участник

      Доброе время суток.

      История непридуманная из жизни. Работает – не трогай.

      Тут решил прояснить для себя пару вопросов по части PowerVM Editions. В принципе я догадывался, что у меня Standard, но….
      Полазил в НМС, ASMI и не нашел как посмотреть, только активизировать.
      Ну и полез на http://www-912.ibm.com/pod/pod. Вбил модель, номер, получил информацию о кодах.
      Взял VET, ну и ввел его(пару раз). Он(POWER) мне честно написал – все хорошо, код принят
      HSCL0420 Введен код PowerVM Standard Edition.
      HSCL0403 Функция сервера виртуального ввода-вывода включена.
      HSCL0405 Функция микроразделения включена.
      HSCL0406 Включены несколько логических разделов.

      Свято веря, что ничего плохого не делаю.
      Но через какое то время пришли люди с вопросом – плохо сеть работает.
      Два LPARа были соединены через virtual LAN (на одном POWER 750). И вдруг резко просела скорость.
      Как эти события связаны между собой – непонятно. Но случились они в одно время.
      И самое главное – что делать, тоже непонятно.

      Вдруг кто сталкивался с подобным ?
      Спасибо.

    • #15613
      andrewk
      Участник

      самый простой способ проверить – перезагрузить сервер целиком 😉 в реальной жизни эти две операции никак не связаны между собой, но я могу себе представить, что когда вводится код, PHype или FSP загружают очередной модуль. Может быть в результате введения кода пару раз были запущены также пару раз пара инстансов какого-нибудь модуля и PHype теперь долго разбирается, через какой конкретно модуль роутить (свитчевать) пакеты. Если дело действительно в этом, то полная перезагрузка сервера поможет решить проблему.
      К сожалению, IBM не выдает практически никакой информации о PHype/FSP и как с ними бороться, а поэтому можно только гадать, советовать обновить микрокод и обратиться в IBM 😉

    • #15615
      Sergey Alexeev
      Участник

      Насчет перезагрузить – это первое что пришло в голову.
      К сожалению, не помогло.
      Вот не знаю, поможет ли обновления микрокода.

    • #15624
      Oleg
      Участник

      а что было критерием “сеть медленно работает”? не пробовали измерять в физических величинах?

      errpt -a | more
      показывает что-то интересное?

      сколько активировано процессоров? как они загружены?
      можете вообще поподробнее о конфигурации?

    • #15626
      Sergey Alexeev
      Участник

      К сожалению уже дома. До машин доберусь в понедельник. Напряженность снял, можно разбираться спокойно.
      В качестве примера с цифрами. На двух LPARах нарезаны в оперативной памяти диски. Один из них дисков доступен другому по NFS. Информация передается с помощью команды dd. Скорость передачи упала с 2.7 Гигабит/сек до 100 Гигабит/сек. Оба LPARа сидят в отдельном VLANе. Процессоры не нагружены. По дискам не пересекаются(у каждого свой выделенный FC-адаптер, на SAN у каждого свой RAID)
      Это как один из самых наглядных.

    • #15634
      Oldnick
      Участник

      а прошивка то какая?

    • #15642
      Sergey Alexeev
      Участник

      AL710_099

    • #15643
      Oldnick
      Участник

      прошивка безусловно устарела, на конец 2010 года. 710 – линейка -самая первая, после нее были 720, 730 и 740.
      есть надежда, что ваш баг уже давно поправлен…

    • #15645
      Sergey Alexeev
      Участник

      Да вот думаю догнать до последней в релизе – AL710_119.
      Если не поможет тогда уж AL730.

    • #15649
      Sergey Alexeev
      Участник

      Тема закрыта. События оказались не связаны друг с другом, просто совпали по времени.
      Пачка Линуксов(RHEL) самопроизвольно просели по скорости, хотя все настройки остались в силе. Потом также (ну после трех перезагрузок) самопроизвольно починились. Остальные линуксы а AIXы работают как и работали. С ситуацией конечно попытаюсь разобраться, но сдается причину не найду до следующего сбоя.

Просмотр 9 веток ответов
  • Для ответа в этой теме необходимо авторизоваться.