Странные проблемы с automount

Главная Форумы POWER Systems AIX/Hardware Странные проблемы с automount

Просмотр 14 веток ответов
  • Автор
    Сообщения
    • #15295
      uxTuaHgp
      Участник

      Долго и успешно монтировались automount-ом по NFS каталоги с Windows сервера с установленным MS SFU.

      В один прекрасный момент, после перезагрузки Win сервера и AIX серверов automount возвращает при попытке прочитать монтируемый каталог:
      The file access permissions do not allow the specified action

      Причем, если руками смонтировать – все отлично.
      Ресурсы AIX серверов automount тоже с удовольствием монтирует.

      На AIX не меняли ничего.
      На Win скорее всего проставились какие-то автообновления.

      Никто с таким не сталкивался?
      Как с этим можно бороться кроме железного монтирования вмсто использования автомонтирования?

    • #15296
      andrewk
      Участник

      нужно смотреть map-файлы для automount, где-то (еще б я помнил, где) включать логгинг и долго-нудно изучать. По опыту работы с automount в AIX – с ним много проблем и некоторые из них лечатся исключительно с помощью бубна.

    • #15297
      uxTuaHgp
      Участник

      что значит map файлы?
      Файлы в которых прописано что и куда монтировать?

      Проблема в том, что не монтируется на куче серверов.
      Нашел вот такое:
      IZ10623: AUTOMOUNTER NOT MOUNTING FILESYSTEMS FROM NON AIX-NFS SERVERS APPLIES TO AIX 6100-02
      Но у меня 6100-06-05-1115

      Стоит сапорт IBM напрячь?

    • #15298
      uxTuaHgp
      Участник

      map-ы простейшие.

      # cat /etc/auto_master
      /net /etc/auto.net
      # cat /etc/auto.net
      someDIR -soft,rw some-win-srv:/someDIR

      Настроил syslog, чтобы он весь дебаг записывал:
      Apr 2 13:32:10 somehost daemon:debug automountd[8913100]: nfs_args=0x2ff212e8 version=3 protocol=0
      Apr 2 13:32:10 somehost daemon:debug automountd[8913100]: Attempt a TCP connection.
      Apr 2 13:32:10 somehost daemon:debug automountd[8913100]: Attempt a UDP connection.
      Apr 2 13:32:10 somehost daemon:debug automountd[8913100]: UDP – Success!
      Apr 2 13:32:10 somehost daemon:err|error automountd[8913100]: some-win-srv:/someDIR server not responding: RPC: Program not registered
      Apr 2 13:32:10 somehost daemon:debug automountd[8913100]: before mount of /someDIR from some-win-srv failed error 78
      Apr 2 13:32:10 somehost daemon:err|error automountd[8913100]: mount of /someDIR from some-win-srv failed
      Apr 2 13:32:10 somehost daemon:debug automountd[8913100]: mount of /net:someDIR status 13

    • #15299
      andrewk
      Участник

      да, именно эти файлики. начиная с /etc/auto_master и все, что у него там внутри написано. А IBM напрячь всегда стоит – деньги-то за поддержку уже уплачены 😉

    • #15300
      andrewk
      Участник

      Apr 2 13:32:10 somehost daemon:debug automountd[8913100]: before mount of /someDIR from some-win-srv failed error 78

      это означает Connection Timed out. rpcinfo -p some-win-srv должно показать кучку портов и среди них mountd, nfs.

    • #15301
      uxTuaHgp
      Участник

      Все есть.
      program vers proto port service
      100000 2 udp 111 portmapper
      100000 2 tcp 111 portmapper
      351455 1 tcp 808
      351455 1 udp 809
      351455 2 tcp 810
      351455 2 udp 811
      100005 1 udp 1048 mountd
      100005 2 udp 1048 mountd
      100005 3 udp 1048 mountd
      100021 1 udp 1047 nlockmgr
      100021 2 udp 1047 nlockmgr
      100021 3 udp 1047 nlockmgr
      100021 4 udp 1047 nlockmgr
      100024 1 udp 1039 status
      100003 2 udp 2049 nfs
      100003 3 udp 2049 nfs

      Если бы не было, то наверное и mount ручками не проходил бы, а он монтирует.

    • #15302
      andrewk
      Участник

      самое главное, что я хотел здесь увидеть – что нет tcp. Я предложил бы в /etc/auto_master жестко прописать proto=udp, рестартовать automountd/automount и попробовать снова.

    • #15303
      uxTuaHgp
      Участник

      я пробовал уже прописывать proto=udp
      ничего не меняется

    • #15304
      andrewk
      Участник

      а в логах тоже самое пишется?

    • #15305
      uxTuaHgp
      Участник

      Вот
      Apr 2 14:30:08 somehost daemon:debug automountd[8913130]: nfs_args=0x2ff212e8 version=3 protocol=17
      Apr 2 14:30:08 somehost daemon:debug automountd[8913130]: Attempt a UDP connection.
      Apr 2 14:30:08 somehost daemon:debug automountd[8913130]: UDP – Success!
      Apr 2 14:30:08 somehost daemon:err|error automountd[8913130]: some-win-srv:/someDIR server not responding: RPC: Program not registered
      Apr 2 14:30:08 somehost daemon:debug automountd[8913130]: before mount of /someDIR from some-win-srv failed error 78
      Apr 2 14:30:08 somehost daemon:err|error automountd[8913130]: mount of /someDIR from some-win-srv failed
      Apr 2 14:30:08 somehost daemon:debug automountd[8913130]: mount of /net:someDIR status 13

    • #15306
      andrewk
      Участник

      можно попробовать еще с tcpdump’ом попробовать отловить, какую же программу он не находит на стороне сервера. можно попробовать выставить nfs_use_reserved_ports – хотя не уверен, что это поможет, т.к. в таком случае бы mount тоже не работал.

    • #15307
      uxTuaHgp
      Участник

      ладно, создал кейс в поддержке.
      Надеюсь решат.

    • #15310
      Alex
      Участник

      Ставлю на то, что что-то поменялось в винде (приехал апдейт какой-нибудь).
      По делу – только tcpdump-ом пытаться отловить, мониторя сессию монтирования.

      про aix support от IBM у меня цензурных слов нет 😉

    • #15311
      uxTuaHgp
      Участник

      боюсь, что придется самим ловить или монтироваться статически через /etc/filesystems…

Просмотр 14 веток ответов
  • Для ответа в этой теме необходимо авторизоваться.