Rpm fail

Просмотр 12 веток ответов
  • Автор
    Сообщения
    • #10073

      Здравствуйте.
      Начал изучать Aix 5.2L.
      При работе с rpm пакетами в любом исходе выдает
      “failed to open /opt/freeware/packages/packages.rpm”
      На что грешить и как бороться.

    • #10074
      andrewk
      Участник

      5.2 – это что-то совсем древнее. Уж не знаю, были ли там rpm, но

      rpm –initdb

      должен по идее спасти.

    • #10081

      Неа, все равно вылезает эта строчка.
      Теоретически rpm имеет место быть)
      Спасибо за совет.

    • #10083
      andrewk
      Участник

      так проверьте, почему не может открыть – есть ли этот файл, есть ли права на запись файла, есть ли права на чтение/исполнение каталога, в котором находится файл, и всех вышестоящих каталогов, какие еще есть файлы в этом каталоге – может там лок от когда-то запущенного rpm’а стоит. Вообще RPM в AIX ничем не отличается от такого же RPM в Linux.

    • #10085

      Его там нет, даже папки такой нет, но он почему то его там ищет.
      На
      rpm –rebuilddb
      ругается теми же словами.
      Я так понимаю там находится база данных rpm?

    • #10089
      andrewk
      Участник

      да, создайте каталог и снова запустите rpm –initdb. он создаст там базу.

    • #10092

      Спасибо большое, сработало.
      Возник вопрос: glibc надо из исходников брать, или есть rpm пакет?

    • #10093
      andrewk
      Участник

      гм. а зачем Вам glibc??? В AIX есть своя libc и если Вы вместо нее попробуете установить гнусное поделие, то с высокой долей вероятности у Вас вообще ничего работать не будет.

    • #10098

      Он при попытке установить gcc-4.2.0 smit ругается на
      /sbin/install-info
      AIX-rpm >=5.3
      /bin/sh
      libc.a(shr.o)

      и еще пару библиотек.
      AIX-rpm >=5.3 – я так понял надо обновить rpm – менеджер. Который так же жаловался на libc.a, а гугл меня привел к мысли о том что эта библиотека устарела, и нужен glibc.

    • #10099
      andrewk
      Участник

      гугл привел Вас к не совсем верной мысли 🙂 Вы ставите пакет, скомпилированный для AIX 5.3 или более нового, на AIX 5.2. Либо апгрейдьте AIX, либо найдите более старую (или скомпилированную для AIX 5.2) версию gcc.
      libc в AIX’е не устаревает 🙂

    • #10100

      Понятно, спасибо большое.
      Какой aix посоветуете, 7 или 6 ?

    • #10101

      Или что нибудь эдакое, что скушает карточку gtx6500p. (intellistation 285)

    • #10105
      andrewk
      Участник

      aix 5.3 и 6.1 скушают без проблем. 7.1 мою 4500 тоже кушает, должен и 6500.

Просмотр 12 веток ответов
  • Для ответа в этой теме необходимо авторизоваться.